Plesk 11.5, TYPO3 und Powermail

Plesk 11.5, TYPO3 und Powermail

Heute habe ich auch wieder einen kleinen netten Tipp für Euch bezüglich TYPO3 und der Extension Powermail im Zusammenhang mit PLESK.

Ich habe mir ehrlich gesagt fast zwei Tage einen Wolf gesucht 🙂

Zur Situation:

Funktionierendes TYPO3 installiert und als Formular-Extension Powermail. So alles hinterlegt, Seite aufgerufen, Formular wird angezeigt und abgeschickt – juhu freu. Aber dann das böse Erwachen, die Mail enthält keinen einzigen Eintrag und in der Datenbank wird die E-Mail auch nicht angelegt.
Was ist da also nun schief gelaufen.

Nachdem ich nun die gesamte Konfiguration und etliche andere Forenbeiträge durchgegangen bin hab ich es immernoch nicht zum laufen gebracht.

Zur Lösung:

Der Fehler ist so banal wie einfach zugleich, es liegt weder an TYPO3 noch an Powermail sondern an der Hosting Umgebung mit Plesk!

Hier habe ich als Standard-URL angegeben das die Domain ohne anführendes „www“ genutzt werden soll, und dies führte letztendlich dazu, das vom Webspace aus keine einzige POST-Variable des Formulares übergebenen wurde.

Ich habe die Einstellung nun auf „Keine“ gesetzt und habe dafür beide Domains im TYPO3 Backend angelegt mit eine Redirect auf die ohne www. Nun funktioniert auch das Formular fehlerfrei.

Torben Müller
x-tec@gmx.de

Torben Müller ist Experte für Online Marketing, SEO und responsive Webdesign. Unter anderem hat er eine anerkannte Weiterbildung zum Social Media Manager und ist Mircosoft Certified Professional. Zu seinen Hobbys zählen unter anderem Tai Chi Chuan und Mountainbiking.

1Comment
  • root
    Posted at 11:52h, 29 Oktober Antworten

    Es hat geholfen.

    Vielen Dank

Post A Comment

Logo Samurai Medien

Samurai Medien realisiert moderne & innovative Webseiten und Online Marketing Lösungen. Bleiben Sie mit Uns in Kontakt.